admin 管理员组文章数量: 1086866
hdu1710 Binary Tree Traversals
原题链接: .php?pid=1710
一:原题内容
Problem Description A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.
In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.
In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.
Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
Input The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
Output For each test case print a single line specifying the corresponding postorder sequence.
Sample Input
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6Sample Output
7 4 2 8 9 5 6 3 1
二:分析理解
题意:根据前序和中序写出后序 前序:1 2 4 7 3 5 8 9 6 中序:4 7 2 1 8 5 9 3 6 求出后序:7 4 2 8 9 5 6 3 1
首先得知道是如何前序遍历、中序遍历、后序遍历的,自己上网查下,我在这里就不多说了
思路:第一步:根据前序可知根节点为1;第二步:根据中序可知4 7 2为根节点1的左子树和8 5 9 3 6为根节点1的右子树;第三步:递归实现,把4 7 2当做新的一棵树和8 5 9 3 6也当做新的一棵树;第四步:在递归的过程中输出后序。
三:AC代码
#define _CRT_SECURE_NO_DEPRECATE
#define _CRT_SECURE_CPP_OVERLOAD_STANDARD_NAMES 1 #include<iostream>
#include<algorithm>using namespace std;int t1[1005];
int t2[1005];void Func(int a, int b, int n, int flag)
{if (n == 1){printf("%d ", t1[a]);return;}else if (n == 0)return;int i = 0;for (; t1[a] != t2[b + i]; i++);Func(a + 1, b, i, 0);Func(a + i + 1, b + i + 1, n - i - 1, 0);if (flag == 1)printf("%d", t1[a]);elseprintf("%d ", t1[a]);
}int main()
{int n;while (~scanf("%d", &n)){for (int i = 1; i <= n; i++)scanf("%d", &t1[i]);for (int i = 1; i <= n; i++)scanf("%d", &t2[i]);Func(1, 1, n, 1);printf("\n");}return 0;
}
#define _CRT_SECURE_NO_DEPRECATE
#define _CRT_SECURE_CPP_OVERLOAD_STANDARD_NAMES 1 #include<iostream>
#include<algorithm> using namespace std;struct Node
{int data;Node* pLeft;Node* pRight;Node(int _data) :data(_data) { pLeft = pRight = nullptr; }
};Node* root;
int N;
int a[1005];
int b[1005];Node* create(int t1,int t2,int num)
{Node* p = nullptr;for (int i = 0; i <num; i++){if (a[t1] == b[t2+i]){p = new Node(a[t1]);p->pLeft = create(t1+1,t2,i);p->pRight = create(t1 + i + 1, t2 + i + 1, num - i - 1);return p;}}return p;
}void postOrder(Node* p)
{if (p == nullptr)return;else{postOrder(p->pLeft);postOrder(p->pRight);if (p == root)printf("%d\n", p->data);elseprintf("%d ", p->data);}
}int main()
{while (~scanf("%d", &N)){for (int i = 0; i < N; i++)scanf("%d", &a[i]);for (int i = 0; i < N; i++)scanf("%d", &b[i]);root = create(0, 0, N);postOrder(root);}return 0;
}
参考博客链接: .html
本文标签: hdu1710 Binary Tree Traversals
版权声明:本文标题:hdu1710 Binary Tree Traversals 内容由网友自发贡献,该文观点仅代表作者本人, 转载请联系作者并注明出处:http://www.roclinux.cn/p/1699467495a355836.html, 本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌抄袭侵权/违法违规的内容,一经查实,本站将立刻删除。
发表评论